Author Topic: Can't really make the 3D work.  (Read 10926 times)

Can't really make the 3D work.
« on: February 06, 2017, 03:51:18 am »
Followed Karpov's instructions on this topic (,29468.0.html)
And the character loads fine in 3D. But not the items. I put any armor on and my character is still naked. This didn't work so I didn't keep trying further.
Any caritative soul can help me with this?

Re: Can't really make the 3D work.
« Reply #1 on: February 12, 2017, 01:14:14 pm »
Is it still in progress or dead?

Offline Lexx

  • Rotator
  • Mexican Apple Thief
Re: Can't really make the 3D work.
« Reply #2 on: February 12, 2017, 08:53:53 pm »
I don't think there are many people around who still know how this stuff works. Also I'm not 100% sure, but didn't some FOnline engine update fucked up big parts of it as well? Kinda surprised the 3d characters are loading at all, tbh. Really a shame this never got finished.

Offline Luther Blissett

  • Moderator
Re: Can't really make the 3D work.
« Reply #3 on: February 15, 2017, 01:57:37 am »
Hello, I'm a ghost from the past (hello, and hope you're all well!) - one thing which may help narrow it down is seeing whether there is a problem with the display of models/textures outright, or if it's just a problem with the link between in the in-game item and the model.

If you go to the old "3D Tutorials and Links" (I assume many of the links are now dead - and all the images have long expired from imageshack or wherever they were hosted, sorry), there was some little tutorials from the times when we were testing things - some of them from before the models were linked correctly - you should be able to test armour/clothing etc by use of the ~param commands.

A lot of the setup info will be obsolete by now - but if you've already got a 3D server working, I'll assume you've got that bit sorted already. If you skip down to the Part One : Admin access and first commands bit, and try some of the param codes from there.

#1 Setting up 3D SDK
Part One
Part Two
Part Three

#2 Testing custom textures example
All parts

You're looking for bits like this:

I probably can't be a lot of use right now, but once... a long time ago, I sort of understood how this all worked - and tried to write it all down in those tutorials. There was definitely a time where we could only add objects through param commands, because the grammar/syntax had changed in the SDK. Karpov did work on updating it at some point.

Anyway, if you can get armour/clothing etc to appear using param codes, the problem may just be in the file where models and objects are linked together (I apologise that I cannot remember which one right now). If models do not show at all, there is a problem... in a different file that I can't remember - but if you look back through posts by myself/Karpov/Graf/Gray etc, hopefully we discussed it on the forum at some point.

I wish I had clearer info to give you, but it's many years ago! I do hope you can make sense of some of this. I would love to see some of this work used for something.

Re: Can't really make the 3D work.
« Reply #4 on: February 17, 2017, 10:36:52 pm »
Many thanks to all of you who replied this topic. Luther, I will try as soon as I possibly can. Couldn't even check back the topic because of my lack of free time.
It's an absolute shit to watch all this work fall into the oblivion. I always been a total supporter. (I suck at 3D so support was the only thing I could do.) And now I slowly work on my old project I would love to add 3D characters and critters. If I'm able to add them... it would be amazing.
As I  said, once I follow step by step Luther's words I will comment and add info here.
Many thanks :)

Offline Luther Blissett

  • Moderator
Re: Can't really make the 3D work.
« Reply #5 on: February 18, 2017, 04:30:52 pm »
Cool - well, I'm glad I happened to stumble across this by chance - I do hope I can help somehow. I've just started having a tiny bit of free time again, after several years with none :)

One thing that makes things a little more difficult to test is that I've been using Linux exclusively for about 3 years now. I did most of this work on my old Windows XP machine. Now, for many files and things, that mostly doesn't matter - but the older SDK from when the 3D was fully working had no Linux client/server in it. The newer ones do have a working Linux client/server apparently, though I can't get the newest ones to work, and so much has changed that I can't just shift files between them.

It also looks like the SDK has changed massively since I last looked at it, e.g. about revision 605, they completely changed the format of absolutely everything, moved all the TLA base files onto a different SDK, and I have no idea where to find the files I need!

I'm quite interested in getting this running again though, if only to give myself a little creative joy and practice :)

Re: Can't really make the 3D work.
« Reply #6 on: February 20, 2017, 11:01:52 am »
It would be amazing to see your work Luther. Glad to see you are interested again!

Also I tried to change the appearance layers using the setcrit param command and only params and doesn't work either. I just change the layer, wether is armor, pants or skin and nothing happens. Funny thing is I have done it way before, years back when you guys shared a link here for a stable SDK with 3D fully implemented. It just won't change the layers or anything.
Also, where can I see the revision version I'm using? cause my SDK is from 3-4 years ago

Offline Luther Blissett

  • Moderator
Re: Can't really make the 3D work.
« Reply #7 on: February 20, 2017, 03:38:38 pm »
It's annoying that those aren't working, as it makes it harder to track down the problem - it could simply be the format of the 3d files have changed and the old ones won't load, but it's hard to tell, without reading pages and pages of Russian changelogs (or perhaps error logs from the game?)

I'm not aware of any easy way to check which revision it is, unless you've downloaded it through SVN, in which case it should be viewable in the SVN programme.

If it's of any use, the old snapshots for stable 3D should still be working if you want to try with thosefrom the old tutorial for the time being.

I'm hoping/imagining I'll be able to do a "diff" between various files of the older (working) and newer revisions to help work out what has changed, and therefore try and work out ways of fixing things. I won't be able to write any new code, but I can possibly read or adjust existing code to maybe get things working.

If your files are not confidential, and you have the internet speed and upload space, is there anyway of uploading your files so I can examine them and see if I can get things working - the fact that you have 3D characters at all is a very good start! Note that this will only work if you've got a new enough SDK for the linux server/client to be present (they'd show up as "FOnline" rather than "FOnline.exe").

No guarantee any of this will work, but I'd love to try!

Offline Luther Blissett

  • Moderator
Re: Can't really make the 3D work.
« Reply #8 on: February 21, 2017, 02:26:22 am »
Cheers for sending the client/server files over, Grey.

I finally solved my linux dependency nightmare (in case anyone else is suffering from the older Linux binaries not running, due to " not found", sudo apt-get install libxft2:i386 will give you the correct libs without screwing up 64 bit libxft-dev).

Anyway, that means I'm successfully running server and client off linux... which means I can do some proper testing now :)

This may take time, but I'll keep you updated.

[edit] One thing that seems missing from our tutorials is the changes in server scripts, for example, it looks like we changed the subsets in _animation.fos amongst other things. Also, I can't get the 3D running off your files, as the registration screen won't load (this could be a linux case-sensitive issue, e.g. example.txt vs Example.txt are read as different files).

I've got a 3D character up and running on Raynor's file from FOnline SDK (non repository, direct download link) but it's running the Van Buren man rather than the Karpov man. I'll be able to work with these files though - the registration works, so it's only a matter of comparing the files in both cases

From re-downloading the things from tutorials etc, the server stuff seems to be missing in all cases (or the re-uploaded file seems to only include the client part). I'm going to search for my old hard drive, which has ALL the files on, which should allow me to compare edits between these files, and then change things until it all works :)
« Last Edit: February 21, 2017, 03:40:34 am by Luther Blissett »

Offline Luther Blissett

  • Moderator
Re: Can't really make the 3D work.
« Reply #9 on: February 22, 2017, 02:40:02 am »
As a quick update, I found my old hard drive. It doesn't sound too healthy, but I think I've managed to back everything up. It'll take a while of research to locate everything and make sense of it (tons of badly named folders all over the place, and no idea what is where, or which was a working version), but I'm sure it's doable. There does indeed seem to be some server/script things in there - I guess Karpov sent me them a long time ago. Importantly it also contains all my notes, which should tell me where lots of things are, and basically log many of the file changes etc

Combining this info with the file changes in the newer SDK should give some clues... I hope.

Of course, if the changes in SDK are too severe between now and then, it may be difficult to find equivalents to change, but we will see. I'm hopeful :)

Re: Can't really make the 3D work.
« Reply #10 on: February 25, 2017, 04:12:18 am »
My results with a recent SDK are summarized here:,29730.0.html

I am very interested in keeping this going and getting it up to speed so keep me updated. I'll try and do some more experiments soon.

Offline Luther Blissett

  • Moderator
Re: Can't really make the 3D work.
« Reply #11 on: February 25, 2017, 01:38:02 pm »
That's really helpful, thanks! I've been having difficulty trying to work things out, as the formatting has changed between versions, so running a compare/diff between pairs of files doesn't work so well. It shows every line as different, because of extra spaces round numbers and syntax. When the formatting is the same, it would simply highlight "this bit of the file is different from that one", which could be a very easy way of working out why one version worked and one didn't.